Transparent Squid Proxy Memakai Jaringan Indihome Untuk RTRW Net

Pengertian Proxy server

Proxy merupakan sebuah server yang berfungsi untuk meneruskan permintaan dari client, menuju jaringan internet atau publik. Proxy server digunakan sebagai web cache yang berfungsi menyimpan history oleh akses dari client sehingga dapat mempercepat proses akses terhadap suatu website. Berikut beberapa fungsi dari Proxy server.

Fungsi Proxy Server

Proxy server akan bertindak melayani request dari clients dalam hal ini adalah jaringan local dengan jaringan internet. Semua akses dari client secara otomatis di akan melewati proxy server sesuai paerameter yang di konfigurasi.

Fungsi utama dari Proxy Server

1. Connection sharing

Bisa bertindak sebagai gateway yang menghubungkan jaringan local dengan jaringan internet. Dengan adanya sambungan bersama sama yang di miliki oleh gateway bisa di sebut conection sharing.

2. Filtering

Bekerja pada layer aplikasi berfungsi sebagai Firewalll paket filtering yang berguna untuk melindungi jaringan lokal. Bisa juga sebagai blokking situs tertentu yang di larang di akses oleh jaringan local.

3. Caching

Proxy Server mempunyai mekanisme penyimpanan obyek-obyek yang diminta dari server-server di internet oleh client.

Nah dalam skema kali ini akan memakai jaringan telkom indihome kemudian squid3 sebagai proxy yang nantinya klient akan di sebarkan melaui jaringan wireless yang nantinya akan digunakan jaringan RTRW net.

Langkah Konfigurasi

Konfigurasi Squid3 proxy server

Konfigurasi IP Address

pico /etc/network/interfaces

auto lo

iface lo inet loopback

auto eth0

iface eth0 inet static

address 192.168.1.1

netmask 255.255.255.0

network 192.168.1.0

broadcast 192.168.1.255

gateway 192.168.1.254

auto eth1

iface eth1 inet static

address 192.168.100.1

netmask 255.255.255.0

network 192.168.100.0

broadcast 192.168.100.255

dns-nameservers 192.168.100.1

simpan keluar

Konfigurasi file resolv.conf

pico /etc/resolv.conf

nameserver 192.168.1.254

Konfigurasi file /etc/sysctl.conf

pico /etc/sysctl.conf

kita cari

# net.ipv4.ip_forward=1

Hilangkan (#)

Restart network

/etc/init.d/networking restart

1.  Tambahkan alamat repository local debian 8, saya menggunkaan kambing UI.

pico /etc/apt/sources.list

deb http://kambing.ui.ac.id/debian/ jessie main contrib non-free

deb http://kambing.ui.ac.id/debian/ jessie-updates main contrib non-free

deb http://kambing.ui.ac.id/debian-security/ jessie/updates main contrib non-free

2. Update debian 8

apt-get update

3. Install squid 3

apt-get install squid3

4. Konfigurasi squid3

pico /etc/squid3/squid.conf

# http_port 3128

menjadi

http_port 3128 transparent

#cache_mem 8 MB

menjadi

cache_mem 64 MB

#cache_mgr webmaster

menjadi

cache_mgr   testing@gmail.com

#cache_dir ufs /var/spool/squid3 100 16 256

menjadi

cache_dir ufs /var/spool/squid3 1000 16 256

#visible_hostname

menjadi

visible_hostname proxy.ujicoba.com

#minimum_object_size  0  KB

menjadi

minimum_object_size  0  KB

#maximum_object_size  4096  KB

menjadi

maximum_object_size  4096  KB

acl localhost src 127.0.0.1/32

tambahkan dibawahnya

acl lan src 192.168.100.0/24

http_access allow localhost

tambahkan dibawahnya

http_access allow lan

5. Konfigurasi selesai lalu simpan

6.  Lihat apakah squid3 sudah benar konfigurasinya

squid3 -k reconfigure

7. Restart squid3

/etc/init.d/squid3 restart

8. membuat rule iptables untuk membelokkan packet ke port 3128

iptables -t nat -A  PREROUTING -i  eth1 -p tcp –s 192.168.100.0/24 -m tcp  --dport 80  -j  REDIRECT  --to-port 3128

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

Jangan lupa masukan konfigurasi iptables di rc.local

9. Simpan konfigurasi iptables di atas di  pico /etc/rc.local

Konfigurasi squid3 proxy server sudah selesai, bila ada yang kurang mungkin para suhu bisa membantu.

Cara memblokir situs dengan menggunakan alamat domain

1. Kita buka lagi squid3

pico /etc/squid3/squid.conf

2. tambahkan konfigurasi berikut

acl CONNECT method CONNECT

tambahkan di bawahnya

acl blok dstdomain  "/etc/squid3/situs"http_access deny blok

3. keluar dari konfigurasi squid3

4. Membuat file    pico  /etc/squid3/situs

di dalamnya kita isi situs yang di blokir misalkan

.facebook.com

.detik.com

.google.com

.detik.com

5. simpan dan keluar

6. kita restart squid3

/etc/init.d/squid3 restart

Konfigurasi Mikrotik

1. setting IP Address

/ip address add address=192.168.100.2/24 interface=ether1

2. setting IP DNS

/ip dns set primary-dns=202.134.0.155 secondary-dns=203.130.196.5 allow-remote-request=yes

3. Menambahkan NAT

/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

4. Menambahkan default gateway

/ ip route add dst-address=0.0.0.0/0 gateway=192.168.100.1

5. Setting Hotspot Interface untuk login user Wireless

[admin@MikroTik] /ip hotspot setup

Select interface to run HotSpot on

hotspot interface: ether2

Set HotSpot address for interface

local address of network: 20.20.20.254/24

masquerade network: yes

Set pool for HotSpot addresses

address pool of network: 20.20.20.2-20.20.20.100

Select hotspot SSL certificate

select certificate: none

Select SMTP server

ip address of smtp server: 0.0.0.0

Setup DNS configuration

dns servers: 20.20.20.254

DNS name of local hotspot server

dns name: myhotspot

Create local hotspot user

name of local hotspot user: admin

password for the user:

[admin@MikroTik] /ip hotspot

Nah sampai di sini setting kita sudah selesai, untuk user dan password konfigurasi default adalah admin password kosong. Untuk Konfigurasi perangkat access point akan di bahas secara terpisah baca disini, nanti bisa berupa ubnt (ubiquiti) kita setting ip address satu network dengan mikrotik kita pilih mode bridge. Semoga berguna.

0 Response to "Transparent Squid Proxy Memakai Jaringan Indihome Untuk RTRW Net "

Post a Comment

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel