Perbedaan Srcnat dan Dstnat di MikroTik

Pengertian tentang NAT (Network Address Translation) merupakan metode untuk menghubungkan lebih dari satu IP Address komputer ke jaringan internet dengan menggunakan satu alamat IP. Metode ini di buat karena ketersedianan alamat IP yang terbatas di jaringan net serta kebutuhan kemanan pada jaringan neighborhood serta kemudahan dalam sistem administrasi jaringan.

NAT bekerja dengan mengalihkan suatu paket facts dari satu IP Address ke alamat IP Address yang lain NAT akan selalu mengingat dari mana asal paket dan kemana tujuan paket dikirimkan, dan ketika ada paket yang kembali maka NAT akan mengirimkannya ke sumber paket. Host dalam jaringan hanya akan menerima paket yang dikirim atau yang diminta sehingga komunikasi bisa berjalan dengan baik.

Dalam konfigurasi MikroTik ada dua type NAT :

srcnat (Source NAT) : pengalihan dijalankan untuk paket data yang berasal dari jaringan nat. NAT dapat merubah alamat IP asal paket dari jaringan yang di nat. Source NAT di lakukan setelah routing saat sebelum paket keluar menuju jaringan. Masquerade  merukanan perumpamaan dari srcnat.

dstnat (Destination NAT) : pengalihan dikerjakan untuk paket data yang menuju jaringan lokal. Cara ini umum digunakan untuk membuat host dalam jaringan lokal dapat diakses dari  jaringan publik (internet). Destination NAT dilakukan saat sebelum routing saat paket dapat masuk dari jaringan. Port Forward, Port Mapping, transparent proxy yaitu perumpamaan dari dstnat.

Kegunaan NAT Pada MikroTik

Source NAT

Apabila ingin menyembunyikan jaringan private LAN kita dengan alamat IP 192. 168. 1. 0/24 dibelakang alamat IP Publik 202. 100. 10. 55 yang didapatkan dari ISP, kita bisa menggunakan fitur source NAT dengan action masquerade. Masquerade dapat merubah alamat IP serta port asal (source port) dari paket yang datang dari jaringan 192. 168. 10. 0/24 ke alamat IP 202. 100. 10. 55 saat sebelum paket keluar dari router.

Misal ketentuan yang bisa kita gunakan yaitu seperti ini :

/ip firewall nat add chain=srcnat action=masquerade out-interface=public

Semua koneksi yang keluar dari jaringan 192. 168. 10. Zero/24 dapat memiliki satu alamat IP yang sama yakni 202. One hundred. 10. Fifty five

Destination NAT

Apabila kita ingin menghubungkan satu alamat IP lokal 192. 168. 10. 30 agar bisa diakses dari jaringan net lewat IP Publik 202. One hundred. 10. Fifty five, jadi kita bisa memakai fitur destination NAT.

Konfigurasi IP deal with publik ke interface publik :

/ip deal with add cope with=202. One hundred. 10. 55/32 interface=publik

Lalu buat ketentuan dengan vacation spot NAT, server inner dapat dibuka :

/ip firewall nat add chain=dstnat dst-address=202. 100. 10. 55 action=dst-nat to-address=192.168. 10.30

Kebalikannya untuk ketentuan server internal dapat bicara dengan jaringan luar yang akan dialihkan ke IP Publik 202. 100. 10. 55 :

/ip firewall nat upload chain=srcnat src-cope with=192. 168.10. 30 action=src-nat to cope with=202. A hundred. 10. 55

Dengan sekenario di atas setiap paket yang menuju jaringan lokal lewat alamat IP Publik 202. 100. 10. 55 dapat diarahkan ke alamat IP lokal 192. 168. 10. 30. Begitupun demikian sebaliknya tiap-tiap paket yang datang dari alamat IP lokal 192. 168. 10. 30 dapat ditukar dengan alamat IP Publik 202. 100. 10. 55 jadi IP Publik dapat melanjutkan paket dari 192. 168. 10. 30 ke jaringan internet.

Mapping 1 : 1

Jika kita ingin menghubungkan IP Publik dengan subnet 10. 10. 10. Zero/24 ke IP lokal dengan subnet 192.168.100. 0/24, Kita gunakan destination NAT dengan action netmap.

Berikut contohnya :

/ip firewall nat add chain=dstnat dst-address 10. 10. 10. 0/24 action=netmap to-deal with=192. 168. A hundred. 0/24

/ip firewall nat upload chain=srcnat dst-address 192. 168. One hundred. Zero/24 movement=netmap to deal with=10. 10. 10. Zero/24

Port Mapping

Kita dapat juga mengalihkan permintaan port tertentu ke server internal didalam jaringan. Hal seperti ini sering digunakan untuk membuka port tertentu:

Berikut contohnya :

/ip firewall nat add chain=dstnat protocol=tcp dst-port=80 in-interface=nearby motion=dst-nat to-deal with=192. 168. 1. 1 to-port=eighty

Perintah diatas mengalihkan seluruhnya paket yang menuju port 80 yang menggunakan protokol tcp yang masuk melalui interface local ke alamat IP Address 192. 168. 1. 1 port eighty.

0 Response to "Perbedaan Srcnat dan Dstnat di MikroTik"

Post a Comment

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel